BMW i4 Forum banner
1 - 9 of 9 Posts

· Registered
Portimao Blue/Tacora Red e40
Joined
·
18 Posts
Discussion Starter · #1 ·
Has anyone run into this issue? My iPhone 13 (pro max) pairs with the car and can send/receive text/calls but is not able to play any music or connect to carplay, it just craps out and says that "CarPlay on (iphone name) has been deactivated. Activate on the device for BMW **** and try again." and just fails. Same thing when I try to play audio over BT, says deactivated.

Took delivery yesterday and the dealership tried everything to get it to work, as it wouldn't work with anyone elses iphone as well. Tech took it back and literally reflashed the entire software and still can't connect to carplay or play audio over BT.
 

· Administrator
2023 i4 m50 Portimao/Oyster
Joined
·
7,766 Posts
What are the CarPlay settings on your phone? This sounds like you might need to enable CarPlay on the phone.
 

· Administrator
2023 i4 m50 Portimao/Oyster
Joined
·
7,766 Posts
ah, great question. i forgot to add that no one’s phone would work, including the BMW techs
Hmmm... upgrade to 11/2022?
 

· Registered
Joined
·
20 Posts
Hey there. Longtime i4 M50 owner here. (7 months). This happened to me a bunch before the recent upgrade. When this happens, turn off the car. Hold down the radio off button for 3 minutes. Don’t cheat. 3 min. Then the I drive restarts. Now. Open the door. Close the door and start the car. Idrive will hard reset like your iPhone. Works for me everytime.

Good Luck.
 

· Registered
Portimao Blue/Tacora Red e40
Joined
·
18 Posts
Discussion Starter · #7 ·
Hey there. Longtime i4 M50 owner here. (7 months). This happened to me a bunch before the recent upgrade. When this happens, turn off the car. Hold down the radio off button for 3 minutes. Don’t cheat. 3 min. Then the I drive restarts. Now. Open the door. Close the door and start the car. Idrive will hard reset like your iPhone. Works for me everytime.

Good Luck.
Followed instructions to a T, no dice 😞
 

· Administrator
2023 i4 m50 Portimao/Oyster
Joined
·
7,766 Posts
currently on 11/2022.31, says no upgrades available
Ah. Yeah, it won't. You're close to current. Not sure what to suggest...
 

· Registered
Apline White 2022 i4 eDrive40
Joined
·
28 Posts
I've had so many issues with CarPlay including inability to connect. Same SW as you .31. Try this: on iPhone go to Settings/General/CarPlay and check to see if if cars you have rented or your i4 is showing under MY CAR. If i4 is showing click "Forget This Car". If i4 not showing, go to the car menu. In car go to Infotainment Section of MyBMW Apps. Select "Connect New Device". Make sure Bluetooth and WiFi are enabled on iPhone. It may ask you to connect to Car's Wifi using a bar code. Then Bluetooth will connect and a Pairing request will come on your phone which you need to click on fairly soon once you see the code. After the pairing is successful you should get in. I had times when it refused to connect. or gave me a Bluetooth error. I had/have the dancing Google Maps GPS which decides to show my location off by as many as five blocks or located on another street or in the ocean and keeps saying "Rerouting" while navigating on Google Maps. Good luck. I feel your pain. My wife has started screen shots before driving. This is what BMW has done to us: ruined our lives. I'm on iPhone 12 and my wife has an iPhone 13.
 
1 - 9 of 9 Posts
Top