BMW i4 Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter · #1 ·
I've only had my e40 for a week, but I've noticed flakiness in CarPlay. Using it to listen to Podcasts (using the Apple Podcasts app), there are periods where it drops out for a couple of seconds, then comes back for a few seconds, and then drops out again for a couple of seconds, and so forth. The first time it happened, I had also been receiving a couple of text messages, so I discounted it as being an anomaly related to that. But the next time it happened I was not receiving any messages. Restarting the infotainment system helped for that trip. On a subsequent trip I had been listening to Podcasts over CarPlay when I received a call. I took the call, and after a period of time the audio dropped and CarPlay went nuts. The caller called back and I was able to answer the call, but none of the CarPlay functionality was there (couldn't even navigate in to CarPlay on the infotainment system). I did not attempt to restart the infotainment because I didn't want the call to disconnect.

Anyone else had unreliability issues? I have an iPhone 12, with all the latest updates.
 

·
Premium Member
2020 330i xDrive Portimao Blue
Joined
·
1,968 Posts
It’s wireless CarPlay, so there may be issues with connection in the car. I assume you’re running iOS 15.6 (current)? How does the WiFi signal strength look when this happens (the WiFi will be in-car WiFi)? CarPlay can be flaky at times. When was the last time you hard booted your iPhone?
 

·
Registered
Joined
·
72 Posts
Discussion Starter · #3 ·
Yeah, iOS 15.6 The last time my phone was rebooted was whenever that was installed, which was maybe 2 weeks ago since that's when 15.6 released. I honestly don't know enough about Wireless CarPlay (I'm coming from a '13 F25 so this is my first vehicle to support CarPlay period) to know if it would actually show a wireless connection on the phone as if you're connected to a 'normal' wireless network, or if there is some hidden connection it's using which wouldn't be apparent to a user. I feel like it's probably the latter because there is no way that BMW would allow whatever web traffic, etc, to go over their embedded cellular connection if a phone is connected via Wireless CarPlay.
 

·
Premium Member
2020 330i xDrive Portimao Blue
Joined
·
1,968 Posts
Yeah, iOS 15.6 The last time my phone was rebooted was whenever that was installed, which was maybe 2 weeks ago since that's when 15.6 released. I honestly don't know enough about Wireless CarPlay (I'm coming from a '13 F25 so this is my first vehicle to support CarPlay period) to know if it would actually show a wireless connection on the phone as if you're connected to a 'normal' wireless network, or if there is some hidden connection it's using which wouldn't be apparent to a user. I feel like it's probably the latter because there is no way that BMW would allow whatever web traffic, etc, to go over their embedded cellular connection if a phone is connected via Wireless CarPlay.
CarPlay uses the normal on-phone WiFi, believe it or not. I typically set it up so my phone uses cellular for everything else (sometimes there’s some weird stuff if it tries to use WiFi since I don’t have the hotspot in my car any more). I’d try a hard reset on the phone to see if that helps. Also, check the WiFi icon when this happens and you can even see how WiFi shows in Settings.
 

·
Registered
Joined
·
768 Posts
Carplay uses a WiFi connection to your car for functionality, when you connect it will say no internet connection, but your data will still work. Should be like this for all cars using wireless car play. I think others who have their i4 can verify this behavior.

Wireless CarPlay uses both the Bluetooth connection and a closed WiFi network to communicate with the phone. This allows both sufficient bandwidth for data exchange (WiFi) and sufficient control protocols to exchange commands with your phone (Bluetooth).

I would think some Apple dev documentation about this is somewhere, but I can't find it.


I'm assuming this is probably happening cause iDrive 8 is super new and just needs some work.
 
  • Helpful
Reactions: gsbaker and ssh

·
Registered
Joined
·
72 Posts
Discussion Starter · #6 ·
So are you suggesting the phone is using WiFi to talk to the car over the closed network, but any data (say viewing i4talk.com) would go out over cellular?
 

·
Premium Member
2020 330i xDrive Portimao Blue
Joined
·
1,968 Posts
So are you suggesting the phone is using WiFi to talk to the car over the closed network, but any data (say viewing i4talk.com) would go out over cellular?
Yes. This is how it should work.

Note: I have had times in my 330 when the phone thinks it can use the WiFi for Internet. Doesn’t end well.
 

·
Premium Member
Joined
·
534 Posts
My car play has been relatively great, one time it didn't connect. Maybe reboot your idrive system as well. Hold the volume button in for 30 seconds (seems longer, lol) and let it reboot. That might take care of some issues.
 
  • Helpful
Reactions: ssh

·
Registered
i4 e40 msport 19" 859M Sunset Orange, cognac vernasca, open pore oak trim
Joined
·
1,854 Posts
My car play has been relatively great, one time it didn't connect. Maybe reboot your idrive system as well. Hold the volume button in for 30 seconds (seems longer, lol) and let it reboot. That might take care of some issues.
When you reboot iDrive hold the volume button until the infotainment screen goes out. Do not hold longer, or wait for the instrument screen to go out.

I did that and the system got into some kind of loop with the whole info screen blinking. It took two more reboots (wo holding too long) to clear that. 🤣
 

·
Premium Member
2020 330i xDrive Portimao Blue
Joined
·
1,968 Posts
When you reboot iDrive hold the volume button until the infotainment screen goes out. Do not hold longer, or wait for the instrument screen to go out.

I did that and the system got into some kind of loop with the whole info screen blinking. It took two more reboots (wo holding too long) to clear that. 🤣
George, did you fall asleep as you held the button? ;)
 

·
Premium Member
2020 330i xDrive Portimao Blue
Joined
·
1,968 Posts
Note: I have had times in my 330 when the phone thinks it can use the WiFi for Internet. Doesn’t end well.
Quick add-on. I do not know if this helps or not, but I have Wi-Fi Assist turned on (in Settings | Cellular near the bottom). Wi-Fi Assist’s purpose is to use cellular data when there are issues of various kinds with Wi-Fi. I do not know if it’s necessary for CarPlay to work the way @Fayt349 outlined (do you know, @Fayt349?), but it seems to have helped with issues sometimes in my 330/iDrive 7.
 

·
Registered
Joined
·
768 Posts
Quick add-on. I do not know if this helps or not, but I have Wi-Fi Assist turned on (in Settings | Cellular near the bottom). Wi-Fi Assist’s purpose is to use cellular data when there are issues of various kinds with Wi-Fi. I do not know if it’s necessary for CarPlay to work the way @Fayt349 outlined (do you know, @Fayt349?), but it seems to have helped with issues sometimes in my 330/iDrive 7.
I don’t have any proof that it’s better to keep on, but it’s only logical to keep it on.

Plus it’s on by default so most likely OP has it on already.
 
  • Like
Reactions: ssh

·
Registered
Joined
·
14 Posts
I would try the iOS 16 beta. I don’t have any firsthand knowledge that it will improve things but I would say it’s worth a try. The current beta is very stable and I’ve seen a lot of backend improvements. You can always revert to an old iCloud backup if ya want.
 
  • Like
Reactions: ssh

·
Premium Member
2020 330i xDrive Portimao Blue
Joined
·
1,968 Posts
I would try the iOS 16 beta. I don’t have any firsthand knowledge that it will improve things but I would say it’s worth a try. The current beta is very stable and I’ve seen a lot of backend improvements. You can always revert to an old iCloud backup if ya want.
Only if you’re comfortable with full backup/restore. I’m running iPadOS 16 on my 12.9” M1 iPad and it’s been solid since the WWDC beta. I haven’t put on my production iPhone, though…
 

·
Registered
Joined
·
14 Posts
Only if you’re comfortable with full backup/restore. I’m running iPadOS 16 on my 12.9” M1 iPad and it’s been solid since the WWDC beta. I haven’t put on my production iPhone, though…
I have found it to be much better on my iPhone than my iPad, for what it’s worth.
 
  • Like
  • Helpful
Reactions: Elle BMW and ssh

·
Registered
‘17 BMW 330ix
Joined
·
15 Posts
I find CarPlay to be effected by what around me when driving. If there are cell towers or some power lines. Mine seems to always drop in the came locations on my current car.
 
1 - 19 of 19 Posts
Top