BMW i4 Forum banner
1 - 17 of 17 Posts

· Registered
Joined
·
62 Posts
Discussion Starter · #1 ·
Seems to be a known problem, but my dear I4M50 was hit by this one also. My BMW -app shows door and window status as Unknown. In practise app does not connect with the car. Error message is shown on display. Interesting to see, if this affects to anything else.
 

· Registered
Joined
·
1,078 Posts
Terrible. A "known problem".

I'm looking in other forums for a 2nd (yet in the flagship level) smartphone and a smartwatch and the threads are FULL of "known problems" that are nearly deal breakers, each and every one of them.
 

· Registered
Joined
·
954 Posts
Android or iOS? Or is it across both platforms?
 

· Registered
i4m50, 18inch 245/255 summer 18 inch 245/245 winter, order aug 21 - Delivery next week?
Joined
·
1,465 Posts
Take a look here:


The ix forum is quite interesting, many of the same discussions as here, but since delivery is 3 months earlier in iX - it is a lot of usefull information that is the same on i4, and iDrive8 is more or less the same.

(I read yesterday somewhere at that forum that this is a known error, and a sw fix had been released for the iX)
 

· Registered
Joined
·
62 Posts
Discussion Starter · #5 ·
Just an update for you. This issue might been caused by BMW’s server (as that was one possible reason).
Checked the car just: no message anymore, battery charged to 100 %. Showing range as 401 km.
Will drive today about that 400, first half motorway (120 km/h) and the rest normal country roads (80 km/h).
Forecasted 6-8 degrees. Plan to use Eco -mode. Interesting to see, what range will be in practise.
Also my 1st charging from public stations…
 

· Registered
Joined
·
7 Posts
Seems to be a known problem, but my dear I4M50 was hit by this one also. My BMW -app shows door and window status as Unknown. In practise app does not connect with the car. Error message is shown on display. Interesting to see, if this affects to anything else.
I have the same problem. It happened for the first time 10 days ago. The problem seemed solved after a day, but it emerged again yesterday evening. I can’t use the bmw app to communicate with my car. The dealer will check the problem.
 

· Administrator
2023 i4 m50 Portimao/Oyster
Joined
·
7,888 Posts
On my 330 I had symptoms like this and deleted the app and reinstalled based on Genius input.
 

· Registered
Joined
·
206 Posts
I have the same problem. It happened for the first time 10 days ago. The problem seemed solved after a day, but it emerged again yesterday evening. I can’t use the bmw app to communicate with my car. The dealer will check the problem.
I'm having the Emergency Call System Malfunction today. Did you get a fix and what was it. Also, my MyBMW app is not communicating.
 

· Registered
2022 i4 eDrive40, Skyscraper Gray, DAPP, PAP, Laserlight, Drive Recorder, eSIM Harmon Kardon
Joined
·
1,702 Posts
To fix this problem the whole tele communication module needs to be replaced. It is not a software problem.
This happened to my car just before delivery. And yes, they said the same thing, whole module needs to be replaced. They are ordering it today. @TheKR
 
  • Sad
Reactions: TheKR

· Registered
Joined
·
50 Posts
Any updates on this? I took delivery yesterday of my M50 and received the alert halfway home from an out of state dealer. I haven’t driven it since, so not sure it will correct itself or remain illuminated in the dash.
 

· Registered
Joined
·
206 Posts
It happened to me the second day I had it, August 1. The Telematic Control Unit malfunctioned. It took two months to get a new one from Germany.
 
  • Like
Reactions: Magicrat

· Registered
2022 i4 eDrive40, Skyscraper Gray, DAPP, PAP, Laserlight, Drive Recorder, eSIM Harmon Kardon
Joined
·
1,702 Posts
@Kief Much like @TheKR it happened to me at delivery, right on the showroom floor. It took two months to get the TCU. Luckily after the dealership consulted with BMW, they said it was ok to drive it while I waited for the part. I think they just wanted my money, LOL. 🤣 🤣
 

· Registered
Joined
·
50 Posts
@Kief Much like @TheKR it happened to me at delivery, right on the showroom floor. It took two months to get the TCU. Luckily after the dealership consulted with BMW, they said it was ok to drive it while I waited for the part. I think they just wanted my money, LOL. 🤣 🤣
Did the warning remain illuminated in your dash during those 2 months that you waited for the part, or did it eventually go out while waiting for the part?
 

· Registered
2022 i4 eDrive40, Skyscraper Gray, DAPP, PAP, Laserlight, Drive Recorder, eSIM Harmon Kardon
Joined
·
1,702 Posts
Did the warning remain illuminated in your dash during those 2 months that you waited for the part, or did it eventually go out while waiting for the part?
It went out at the dealership and never returned. The service guys might have done something to stop the display of the error. They had the car for a week, working with BMW NA, and then they called and said it was safe to drive but lots of the features of the iDrive software wouldn't work like maps, etc. Works fine now.
 

· Registered
Joined
·
50 Posts
It went out at the dealership and never returned. The service guys might have done something to stop the display of the error. They had the car for a week, working with BMW NA, and then they called and said it was safe to drive but lots of the features of the iDrive software wouldn't work like maps, etc. Works fine now.
Ok, thanks for sharing. Yeah, everything seems to be working with mine ever since the warning went off (knock on wood)
 
1 - 17 of 17 Posts
Top